[sheepdog] [PATCH 6/6] sheep: refactor start_deletion

MORITA Kazutaka morita.kazutaka at gmail.com
Mon Apr 29 00:35:07 CEST 2013

At Sat, 27 Apr 2013 13:44:22 +0800,
Liu Yuan wrote:
> From: Liu Yuan <tailai.ly at taobao.com>
> - rename dw_siblings as list
> - squash vdi_get_root into vdi_fill_list

I'd suggest splitting these changes into different ones.  It makes it
much easier to review this patch.

> -static int fill_vdi_list(struct deletion_work *dw, uint32_t root_vid)
> +static uint64_t vdi_get_root(uint32_t vid, bool *cloned)
>  {
> -static uint64_t get_vdi_root(uint32_t vid, bool *cloned)
> +static int vdi_fill_list(struct deletion_work *dw)
>  {

I think changing the order of these two functions makes it very hard
to review this patch.  Can you prepare another one to change this



More information about the sheepdog mailing list