[sheepdog] [PATCH 0/2] introduce wrappers of pthread_mutex_* and pthread_cond_*

Hitoshi Mitake mitake.hitoshi at gmail.com
Wed Dec 25 14:34:37 CET 2013


This patchset introduces new wrappers for pthread_mutex_* stuff and
pthread_cond_* stuff.

The first one renames existing wrappers of pthread_rwlock_* things. Currently,
the naming convention based on "sd_lock" is used for the wrappers. The name is
confusing if we add new wrappers based on "sd_mutex". So the first one renames
the existing wrappers from "sd_lock" to "sd_rw_lock".

The second one adds new wrappers for pthread_mutex_*. It also adds new wrappers
for pthread_cond_*. Because we don't use pthread_mutex_* directly, we also need
to wrap pthread_cond_* for pthread_cond_wait().

Hitoshi Mitake (2):
  lib: rename wrappers of pthread_rwlock
  lib: introduce new wrappers for pthread_mutex and pthread_cond

 dog/farm/farm.c           |   4 +-
 include/util.h            | 118 +++++++++++++++++++++++++++++++++++++++++++---
 lib/event.c               |   8 ++--
 lib/sockfd_cache.c        |  22 ++++-----
 lib/work.c                |  71 ++++++++++++++--------------
 sheep/cluster/local.c     |   6 +--
 sheep/cluster/zookeeper.c |  56 +++++++++++-----------
 sheep/group.c             |  16 +++----
 sheep/md.c                |  24 +++++-----
 sheep/object_cache.c      |  30 ++++++------
 sheep/object_list_cache.c |  16 +++----
 sheep/request.c           |  10 ++--
 sheep/sheep_priv.h        |   2 +-
 sheep/trace/trace.c       |  12 ++---
 sheep/vdi.c               |  14 +++---
 sheepfs/volume.c          |  16 +++----
 16 files changed, 264 insertions(+), 161 deletions(-)

-- 
1.8.1.2




More information about the sheepdog mailing list