First I would like to apologize for my bad English. I made patched wpkg.js file (version 1.1.0-M6), at which I tried implement new functionality I have asked here http://lists.wpkg.org/pipermail/wpkg-users/2008-February/002636.html . You can download this file from vorlicek.web.tiscali.cz/Files/wpkgpatch.zip . So, what are new features? At hosts.xml it's possible to use now this attributes: name system ou group username userou usergroup At command line it's possible to use this parameters: /applymultiple /noldap /host:<hostname> /ip:<ipaddresses> /system:<hostsystem> /user:<username> Detailed description of attributes and parameters is at zip file. I plan to run wpkg not only at startup, but also at logon and logoff. At startup I will use it for it's default usage - installation/upgrade software (and changes at shared folders and HKLM). At logon and logoff I will use it for changes at user profiles and HKCU (most of them only once executed). New functionality allow me define hosts for it. This is example of host.xml file: <wpkg> <host ou="Classrooms" profile-id="Classrooms"/> <host ou="Classrooms" usergroup="Domain Users" profile-id="Domain Users on Classrooms"/> <host ou="Classrooms" usergroup="Teachers" profile-id="Teachers on Classrooms"/> <host ou="Classrooms" usergroup="Students" profile-id="Students on Classrooms"/> <host ou="Classrooms" username="Administrator" profile-id="Administrator on Classrooms"/> </wpkg> I start wpkg.js at cmd script via GPO. I don't use WPKG Client. For determining which profiles are used during startup,logon and logoff I plan to use three xml files of profiles (profiles-startup.xml, profiles-logon.xml, profiles-logoff.xml). I testet patched script on Windows XP Professional SP2 computers joined to Windows Server 2003 domain. It works for me well. But I don't know, how it works on other operating systems (Windows 2000 or Vista), at environment without domain or at multi-domain environment. Script must be checked. I never wrote in javascript before, so there will be probably errors in code! I don't speek English well, so there may be mistakes in comments. Internally main changes of script are at function getHostNode, which I completely rewrote. And because now it gives array of nodes instead of one node, I had to rename it to getHostsApplying (name getHostNodes was already used). Minor changes are at functions getHostProfiles and getProfileList. Many new functions were added. So. Test it please. And if you think, that other users could take advantage of this new features, you can use this patch or it's parts as you want. You can of course do any changes you want. You can also rename above attributes - they needn't be strict as I wrote. Notice: System attribute should be (maybe) used at <package> instead of <host> as wanted at http://lists.wpkg.org/pipermail/wpkg-users/2008-May/003278.html ? Jindrich Vorlicek |