[sheepdog-users] Write till the end of the cluster

Valerio Pachera sirio81 at gmail.com
Thu Dec 13 14:34:13 CET 2012

Well, went forward with the messing :-)

I killed a node and added new bigger node of 10G.
The recovery has been fast.
	collie node info
	Id      Size    Used    Use%
	0      982 MB  956 MB   97%
	1      982 MB  568 MB   57%
	2      10.0 GB 1.4 GB   14%
	Total   12 GB   2.9 GB   24%

Without rebooting the guest I tried to write a small amount of data by dd
  dd if=/dev/zero of=/mnt/sda1/smallfile bs=1M count=128 but
but I had to stop it because it was very slow.

I tried to poweroff the guest but i hanged up, so I had to kill it.
After the reboot, it was not possible to mount sda1
   '/dev/sda1 can't read superblock'.
I tried then
   xfs_repair -L /dev/sda1
   xfs_repair: pwrite64 failed: Input/output error
   <repeated severl times>
dmesg is showing I/O errors
	Dec 13 11:59:05 [io 7284] prealloc(303) failed to preallocate space,
No space left on device
	Dec 13 11:59:05 [io 7284] err_to_sderr(129) diskfull, oid=7c2b25000002f1
        <repeated several times>
After that I was able to mount sda1.
I tried to run dd again with small data amount but this time I was not
even able to stop it.
I had to kill the guest. Note: before write anything, I removed all
file from /mnt/sda1.
I', trying now to check the disk consistency
  collie vdi list
    Name        Id    Size    Used  Shared    Creation time   VDI id
Copies  Tag
    test         1   10 GB  3.4 GB  0.0 MB 2012-12-13 11:46   7c2b25     2
  collie vdi check test
      Failed to read, No object found

More information about the sheepdog-users mailing list