[sheepdog-users] vdi problem

MORITA Kazutaka morita.kazutaka at gmail.com
Wed Jun 12 14:06:39 CEST 2013

At Tue, 11 Jun 2013 15:07:54 +0200,
Valerio Pachera wrote:
> I open a new tread for this problem.
> Summary: a guest named 'backup' was running on top of the host "sheepdog004".
> Guest was using cache; cluster was still version 0.5.6xxx.
> The host died.
> I run the guest on another host and created one snapshot.
> When sheepdog004 was back online it was showing the vdi of the
> snapshot without the 's' and with id 0.
> Note: cache has been delete from sheepdog004 without being flushed

How did you delete the cache?

> (because guest was already running on another host).
> I create a second and third snapshot and removed the first.
> I tired kill the node sheepdog004 and insert it backup as soon as
> possible, but vdi list was still wrong.
> I also update sheepdog to version 0.6.0 and then to 0.6.0_23_gd0b2857.
> Today I killed the node again, clear all its data and insert it back.
> Now it's showing the right vdi list.
> I run the guest "backup" on the node "sheepdog001" and it seems to be
> working fine (during recovery) but I noticed it's showing a 'c' near
> the 's' of snapshot id 3! [*]

Showing only 'c' is possible, but showing both is impossible.  I have
no idea about what's going on your cluster...

> I would like to understand if data are safe in this vdi or not.
> It's 1T of data!

Can you run md5sum against the strange objects directly and give us
the results?  The filename is 80c8d12900000000 and you can find it in
obj directories on some nodes.  I guess there is inconsistency



More information about the sheepdog-users mailing list