[sheepdog-users] sheepdog about clone

Valerio Pachera sirio81 at gmail.com
Thu May 15 16:08:08 CEST 2014

2014-05-13 9:18 GMT+02:00 飞 <duron800 at qq.com>:

> hello, I have a question for clone a sheepdong image.
> my clone steps are:
> 1. I create a image named myimg
> 2. I write some files to  myimg
> 3. I create a snapshot named 'newest', dog vdi snapshot -s newest myimg
> 4. I ran 'dog vdi clone -s newest myimg myimg2'
> 5. I ran 'dog vdi delete myimg'
> 6. I attach the myimg2 to QEMU, but I can't found the files I wrote at
> step 2.

I confirm such behaviour.
(I'm running latest master branch 'Sheepdog daemon version

More precisely it happens if the snapshot is taken with the running guest.
I created 250 files of 1M each inside the guest and run 'dog vdi snapshot'
as soon as dd was done.
I turned off the guest; cloned the snapshot and run the guest from the
cloned vdi.
The guest was showing all 250 file but many of them were empty!
Also bash history was not saved.

If I do the same thing but shutting down the guest before taking the
snapshot, then all data is present on the cloned vdi (bash history

Is it possible to force sheepdog to send a 'sync' request when taking the

Does 'dog vdi cache flush' has effect only on  object cache?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wpkg.org/pipermail/sheepdog-users/attachments/20140515/14ebfe76/attachment-0005.html>

More information about the sheepdog-users mailing list