[sheepdog-users] problem starting sheepdog

Valerio Pachera sirio81 at gmail.com
Mon Jul 13 11:34:27 CEST 2015

2015-07-13 11:16 GMT+02:00 Hitoshi Mitake <mitake.hitoshi at gmail.com>:

> Does the cluster cannot see even after 10:41:43? The time
> stamp of cluser's last log entry is 10:41:07. I'd like to clarify it.

First and last log because the cluster is new.

I run

sheep -n \
-c zookeeper:,, \

on all 4 nodes (at 10:41) but the third node doesn't join the others.

I tried now to kill sheep on the third node and run it again but it still
doesn't join the cluster

root at testc:~# dog node list
  Id   Host:Port         V-Nodes       Zone
   0         3  771926208

root at testc:~# cat /var/lib/sheepdog/sheep.log
Jul 13 11:30:12   INFO [main] md_add_disk(368) /mnt/sheep/0, vdisk nr 9,
total disk 1
Jul 13 11:30:12   INFO [main] zk_init(1498) version 3.4.5, address,,, timeout
Jul 13 11:30:12   INFO [main] zk_init(1503) the negociated session timeout
is 30000
Jul 13 11:30:13 NOTICE [main] get_local_addr(522) found IPv4 address
Jul 13 11:30:13   INFO [main] send_join_request(1083) IPv4 ip:
port:7000 going to join the cluster
Jul 13 11:30:13 NOTICE [main] nfs_init(645) nfs server service is not
Jul 13 11:30:13   INFO [main] check_host_env(539) allowed open files set to
suggested 830000
Jul 13 11:30:13   INFO [main] main(1040) sheepdog daemon (version
0.9.0_190_gaa4d885) started
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wpkg.org/pipermail/sheepdog-users/attachments/20150713/5a0ed054/attachment.html>

More information about the sheepdog-users mailing list