[Sheepdog] [PATCH v2 2/3] sheep: refactor local and io request handling

MORITA Kazutaka morita.kazutaka at lab.ntt.co.jp
Tue Nov 22 07:59:53 CET 2011

At Mon, 21 Nov 2011 20:11:22 +0800,
Liu Yuan wrote:
> From: Liu Yuan <tailai.ly at taobao.com>
> They don't share any code or logic, let's split 'em out.
>  - add a new function to handle local request.
> other minor changes:
>  - rename store/cluster_queue_request into do_io/cluster_request to conform naming in ops.c
>  - rename forward_*_obj_req into do_cluster_*, since we don't truely forward the
>    io requests. We have to do local io if requested object is local stored. I think
>    'cluster' is more appropriate.

It's confusing to use 'cluster' name for the operations that do not
use corosync multicast.  'forward' looks better to me.



More information about the sheepdog mailing list