[sheepdog] [PATCH 2/6] sheep: use different opcodes for internal read/write I/O

Liu Yuan namei.unix at gmail.com
Wed Jul 4 05:23:06 CEST 2012


On 07/04/2012 03:54 AM, Christoph Hellwig wrote:
> +	/* peer I/O operations */
>  	[SD_OP_REMOVE_OBJ] = {
>  		.type = SD_OP_TYPE_IO,
>  		.process_work = store_remove_obj,
>  	},

For better name consistent, it's better to rename store_remove_obj as
store_remove_peer. Or even more aggressive,
peer_{read,write,create_and_write,remove}, because store_ prefix doesn't
carry any meaningful implication after we abstract backend store out.

And I think SD_OP_TYPE_IO -> SD_OP_TYPE_PEER would be better too.

Thanks,
Yuan




More information about the sheepdog mailing list