[sheepdog] filesystem errors when using sheepdog

Hitoshi Mitake mitake.hitoshi at gmail.com
Fri Jul 17 16:07:14 CEST 2015

On Fri, Jul 17, 2015 at 10:59 PM, Vasiliy Tolstov <v.tolstov at selfip.ru> wrote:
> 2015-07-17 16:49 GMT+03:00 Hitoshi Mitake <mitake.hitoshi at gmail.com>:
>> I'd like to confirm some points:
>> - can you reproduce the no obj found problem on current sheepdog and
>> qemu without enabling discard?
> not, all works fine witout discard

So do you mean without discard, there's no problem without the
serialization patch?
I need to confirm that the serialization patch can solve the problem
at least in a case of no discard.

I cannot find DISCARD_OBJ in your error log, so I think the problem
can happen without discard in the previous qemu.

>> - is the problem solved with qemu with serialization patch without
>> enabling discard?
> yes it solved, if you send to qemu-devel may be this patch goes to 2.4.0.
> --
> Vasiliy Tolstov,
> e-mail: v.tolstov at selfip.ru

More information about the sheepdog mailing list