[Stgt-devel] [Patch 1/2] Add dynamic lu configuration.
FUJITA Tomonori
fujita.tomonori
Fri Jun 15 00:20:47 CEST 2007
>
> Signed-off-by: Mark Harvey <markh794 at gmail.com>
> @@ -286,18 +286,29 @@ int spc_illegal_op(int host_no, struct scsi_cmd *cmd)
> }
>
> enum {
> - Opt_scsiid, Opt_scsisn, Opt_err,
> + Opt_scsiid, Opt_scsisn,
> + Opt_vendorid, Opt_productid,
> + Opt_productrev, Opt_sense_format,
> + Opt_removable, Opt_online,
> + Opt_err,
> };
>
> static match_table_t tokens = {
> {Opt_scsiid, "scsi_id=%s"},
> {Opt_scsisn, "scsi_sn=%s"},
> + {Opt_vendorid, "vendor_id=%s"},
> + {Opt_productid, "product_id=%s"},
> + {Opt_productrev, "product_rev=%s"},
> + {Opt_sense_format, "sense_format=%s"},
> + {Opt_removable, "removable=%s"},
> + {Opt_online, "online=%s"},
> {Opt_err, NULL},
> };
I want name consistency here though I'm not arguing that Opt_scsiid
and scsi_id / Opt_scsisn and scsi_sn naming is the best choice.
Previously, you used:
> + {Opt_VendorIdent, "VendorIdent=%s"},
> + {Opt_ProductIdent, "ProductIdent=%s"},
> + {Opt_ProductRev, "ProductRev=%s"},
> + {Opt_SenseFormat, "SenseFormat=%s"},
> + {Opt_Removable, "Removable=%s"},
> + {Opt_Online, "Online=%s"},
I'm ok with changing Opt_scsiid and scsi_id / Opt_scsisn and scsi_sn
naming.
Suggestions?
More information about the stgt
mailing list