[Stgt-devel] Different throughput numbers on SLES 10 and RHEL 5.1

Erez Zilber erezz
Tue Feb 12 10:59:49 CET 2008


I'm using the latest stgt release (tgt-20071227) and I see different
throughput numbers for READ commands on SLES 10  & RHEL 5.1. I'm using
stgt with iSCSI over iSER.

I'm using the same initiator (open-iscsi 865.15 from OFED 1.3 rc4) and
the same target machine. The target machine has 2 partitions - one is
SLES 10 & the other is RHEL 5.1. When I run READ commands against the
target on SLES 10, I get ~400 MB/sec (which is the throughput of the
LUN). When I run the same READ commands from the same initiator against
the target on RHEL 5.1, I get only 240 MB/sec.

Is there anything that I need to config on the RHEL 5.1 machine? BTW -
if I run the same test directly from the target machine, I get 400
MB/sec on both distros.

Here's the command that I use:

sgp_dd if=/dev/sdc of=/dev/null bs=512 bpt=1024 thr=8 time=1 count=20480000


More information about the stgt mailing list