[stgt] VTL tape not working

Albert Pauw albert.pauw at gmail.com
Mon Feb 23 21:07:02 CET 2009

FUJITA Tomonori wrote:
> On Sun, 22 Feb 2009 09:14:42 +0100
> Albert Pauw <albert.pauw at gmail.com> wrote:
>> it works now, thanks.
> Nice, thanks.
>> Just one more thing, using tgtimg I can set the size of the tape.
>> However, there is no limit writing to it. Some backup software actually 
>> relies on
>> the tape reaching the end of the tape before trying to get another tape 
>> from the library.
>> Shouldn't the ssc_bs return an EOT at the size previously set with tgtim?
> Yeah, we don't use 'the size' set with tgtimg now. I'll put this on my
> todo list.

the last commit you did, instead of the patch you send me before (tgtadm 
patch) it patched
target.c, but it doesn't work for me.

I made the startup initd script verbose (-vx option) and tried to see 
what is happening when starting up.

Here's the last bit:

+ case $1 in
+ start
+ echo 'Starting target framework daemon'
Starting target framework daemon
+ tgtd
+ '[' 0 -ne 0 ']'
+ tgtadm --op update --mode sys --name State -v offline
+ tgt-admin -e -c /etc/tgt/targets.conf
tgtadm: tgtd closed the socket
tgtadm: can't get the response, Connection reset by peer
    tgtadm --lld iscsi --op update --mode logicalunit --tid 1 --lun=1 
--params removable="1"
exited with code: 104.
+ tgtadm --op update --mode sys --name State -v ready
tgtadm: can't send the request to the tgt daemon, Transport endpoint is 
not connected.

One tgtd process is killed, the other hangs for ever, until I kill it 
with -9.

When I reversed your last commit (force ssc to use bs_ssc) and inserted 
your previous patch it works fine again.


To unsubscribe from this list: send the line "unsubscribe stgt" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

More information about the stgt mailing list