[wpkg-users] patch for 0.9.9.test3 2nd try

Tomasz Chmielewski mangoo at wpkg.org
Thu Jun 22 17:00:59 CEST 2006

Tomasz Chmielewski wrote:
> Tomasz Chmielewski wrote:
>> Gordon.Klimm at gmx.net wrote:
>>> [this time with the actual patch :-)]
>>> here is a patch against 0.9.9.test3
>>> it handles:
>>> * replace "if (debug)" with "dinfo" on several occasions (for readability)
>>> * there is an error: lines #1734 and line #1740 are mixed up(1),
>>> * in "reboot()" the fso "filesystemobject" is to be used by "default" only.
>>> (1) these lines ["requires an immediate reboot."] and ["is not an error."] are exchanged within every version i can remember. 
>>> so no important changes, just cosmetic ones.
>> Hmm, when is "requires an immediate reboot" used anyway (some examples)?
> OK, I see, but there seems to be a bug in "upgarde" and "remove" with 
> regard to reboot="true" for a given exit code?

I have it, it was this code in upgrade and remove functions, and also 
existed in every version I can remember: :)

             // if found, command was successful
             if (exitNode != null) {
                 info("Command in removal of " + packageName + " 
returned " +
                     "non-zero exit code [" + result + "]. This exit 
code " +
                     "is not an error.");

Tomasz Chmielewski

wpkg-users mailing list
wpkg-users at lists.wpkg.org

More information about the wpkg-users mailing list