[wpkg-users] profile question

Natxo Asenjo natxo.asenjo at gmail.com
Mon Feb 21 20:09:53 CET 2011

On Mon, Feb 21, 2011 at 5:31 PM, Falko Trojahn
<nospam_ft at smi-softmark.de> wrote:
> Am 21.02.2011 14:14, schrieb Natxo Asenjo:
>> On Fri, Feb 18, 2011 at 2:09 PM, Falko Trojahn

> Did you make the "openmanage-32bit" _package_ depend from package
> "is_primergyrx300_s3"?
> Cause, regarding priority, wpkg can install  "openmanage-32bit"  before
> trying to install "is_primergyrx300_s3" when it has higher priority ...

no, they are independent from each other.

What I have done now is make the openmanage-32bit package dependent on
the is_poweredge_r410 package. Only the openmanage-32bit is in the
profile poweredge_r410.

So in order to install the openmanage-32bit package, the
is_poweredge_r410 has to be true. This is the check:

@echo off

rem if %errorlevel% of this command is 0, then it is a PowerEdge R410

wmic  computersystem get model | findstr /i "PowerEdge R410"

When I run this from a cmd.exe in a fujitsu primergy server, it
returns %errorlevel% 1 (the string is not found, it is not a dell
poweredge 410).

By the way, this is the output of wmic computersystem get model in
this primergy server

C:\>wmic computersystem get model

When I run it from wpkg, it returns 0:

Execute check for program 'C:\WINDOWS\system32\cmd.exe /c
%software%\dell-openmanage\check_dell_pe_r410.cmd' returned '0'.
Evaluating condition 'exitcodeequalto' revealed true when comparing to
expected value of '0'

this is the package:

        name="check if this is a Dell PowerEdge R410"
        priority="10000" >

        <check      type="execute"  path="%COMSPEC% /c
condition="exitcodeequalto" value="0" />


So it is not returning the right %errolevel%, so the check is met and
the dependency gets installed. Weird.

Any idea as to why this is?



More information about the wpkg-users mailing list