[wpkg-users] WPKG running as local system unable to download profiles.xml file

Troy Hamilton troy.a.hamilton at gmail.com
Tue Jul 29 20:19:49 CEST 2014

Hi Antony,

> When I run wpkg.js as a user or administrator, it runs fine and it is
able to download profiles.xml and other xml files.
> when I run wpkg.js as local system, it is unable to download profiles.xml
and other xml files.

> I thought this would be a windows firewall problem, but windows firewall
is turned off on the client.

> Has anyone run into this problem? Any ideas?

Can you try using psexec.exe or beyondexec.exe with the -s option to remote
into the problem computer(s) and execute wpkg as the system account to see
if it gives any helpful error messages?

In my organization (about 2,500 computers), I use a custom WPKG service
running as the system account to execute wpkg.js.  This works great on 98%
of them, but I have a handful of workstations in remote offices with T-1
lines that have trouble.  On these few computers, I get an error that "The
account is not authorized to login from this station."  But if I RDP into
the computer, open Windows Explorer, browse to \\server\share\<WPKGROOT>
and then start my WPKG service, then it runs just fine.  The error message
that I'm getting could be caused by conflicting SMB signing policies or bad
DNS records, but it seems strange that it works after opening the UNC path
from the workstation (with a different user account).

Hopefully the beyondexec.exe or psexec.exe method can reveal a helpful
error message even if it's not the same problem I'm seeing.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wpkg.org/pipermail/wpkg-users/attachments/20140729/9cc913c8/attachment-0003.html>

More information about the wpkg-users mailing list