On 06/25/2012 01:31 PM, MORITA Kazutaka wrote: > It looks better to make write_info > > struct write_info { > struct pollfd pfds; > struct sd_vnode *vnodes; > }; > > and define wi as > > struct write_info wi[SD_MAX_REDUNDANCY]; The only benefit I can see is that we can use a single memmove() call to update write_info. But use three memmove() doesn't do harm and this structure change will cause a lot of rebasing and we can't add more structure member as nr_sent to the structure. So I think package all the write info struf into write_info is okay at least to this initial version. If any modification is really needed, we can patch it on demand. Thanks, Yuan |