[wpkg-users] patch for 0.9.9.test3 2nd try
Tomasz Chmielewski
mangoo at wpkg.org
Thu Jun 22 16:06:04 CEST 2006
Gordon.Klimm at gmx.net wrote:
> [this time with the actual patch :-)]
>
> here is a patch against 0.9.9.test3
>
> it handles:
> * replace "if (debug)" with "dinfo" on several occasions (for readability)
> * there is an error: lines #1734 and line #1740 are mixed up(1),
> * in "reboot()" the fso "filesystemobject" is to be used by "default" only.
>
> (1) these lines ["requires an immediate reboot."] and ["is not an error."] are exchanged within every version i can remember.
>
> so no important changes, just cosmetic ones.
Hmm, when is "requires an immediate reboot" used anyway (some examples)?
@@ -1731,13 +1734,13 @@
// this exit code forces a reboot
info("Command in removal of " + packageName + "
returned " +
"non-zero exit code [" + result + "]. This
exit code " +
- "is not an error.");
+ "requires an immediate reboot.");
reboot();
} else {
// this exit code is successful
info("Command in removal of " + packageName + "
returned " +
"non-zero exit code [" + result + "]. This
exit code " +
- "requires an immediate reboot.");
+ "is not an error.");
continue;
}
}
--
Tomasz Chmielewski
http://wpkg.org
_______________________________________________
wpkg-users mailing list
wpkg-users at lists.wpkg.org
http://lists.wpkg.org/mailman/listinfo/wpkg-users
More information about the wpkg-users
mailing list