[wpkg-users] ghostware?

Nils Thiele it.service.kultur at uni-hamburg.de
Tue Apr 11 10:12:37 CEST 2017

Am 07.04.2017 um 15:02 schrieb Carlos R. Pasqualini:
> El vie, 31-03-2017 a las 10:23 +0200, Nils Thiele escribió:
>> Hi,
>> What unresolved issues do you have with the gpe execution on windows
>> 10?
>> At least with fastboot disabled (we have SSDs in all current systems)
>> it works fine on all system we have shipped so far (Clean install,
>> Enterprise LTSB 2016 and Education).
>> I would love to be able to improve the boot execution method of
>> wpkg-gp but since its developed in c++ its out of my league.
> Hi Nils!
> did I miss something?
> I have wpkg-gp 0.17.16 in a non active directory environment, Windows 10
> Professional, with a public samba share that works OK when I run wpkg-js
> from cscript.exe but wpkg-gp is unable to find the share on startup.
> Same environment worked great for years... with Windows 7 since wpkg-gp
> 0.15 (it was hosted on googlecode at that time). Right now I have few
> Windows 7 machines and they are working good, but not even one Windows
> 10. Right now I'm going from time to time to each machine and mannually
> running a script for upgrading.
> I have not been able to get a working environment since windows 10 had
> arrived; I was designing an Active Directory environment to this network
> as a way to run wpkg-gp from group policy, but it would be really great
> to have it running without Active Directory using wpkg-gp on startup or
> on shutdown.
> May be I'm not using the latest binary as I cannot see a good place to
> go and 'download the latest binary
> not in https://github.com/sonicnkt/wpkg-gp/
> not in https://github.com/cleitet/wpkg-gp/wiki
> and not in https://wpkg.org/WPKG-GP
> I think that would help to add some info somewere on where is the latest
> version of wpkg-gp and where to report issues. There is not an 'official
> github repo' for the wpkg-gp project, may be it would be a good idea to
> have one with write access for a few devs.
> Honestly, I thought in line with the things expressed by Heiko, that
> there was some pending work on wpkg-gp to be reliable on Windows 10.
> Another 'may be': may be I'm doing something wrong and it is only my
> fault :-)
> Just in case my wpkg-gp.ini is:
> (removing comments and white lines)
> grep -v ^# Wpkg-gp.ini|grep -v -e '^[[:space:]]*$'
> [WpkgConfig]
> EnableViaLGP = 1
> IgnoreGroupPolicy = 0
> DisableAtBootUp = 0
> WpkgCommand =\\someservername\wpkg\wpkg.js
> WpkgVerbosity = 3
> WpkgNetworkUsername =
> WpkgNetworkPassword =
> WpkgMaxReboots = 3
> WpkgRebootPolicy = force
> WpkgExecuteByNonAdmins = 1
> WpkgExecuteByLocalUsers = 1
> WpkgActivityIndicator = 1
> TestConnectionHost = someservername
> TestConnectionPort = 445
> TestConnectionTries = 8
> TestConnectionSleepBeforeRetry = 5
> ConnectionTries = 10
> ConnectionSleepBeforeRetry = 5
> [EnvironmentVariables]
> Besides all of this, a big thanks to all for this excellent work!
> Best regards
> Carlos Pasqualini
> ---------------------------------
> wpkg-users mailing list archives >> http://lists.wpkg.org/pipermail/wpkg-users/
> _______________________________________________
> wpkg-users mailing list
> wpkg-users at lists.wpkg.org
> https://lists.wpkg.org/mailman/listinfo/wpkg-users

Hi Carlos,

How does the your Login name look like for the samba share? do you 
specify the workgroup? or is it really completely public without login?

My setup:

WpkgNetworkUsername = WORKGROUP\wpkg

The rest looks identical to our config file.
I am using a basic ubuntu server with just a samba share as well, no AD.

The only difference is that we are using Windows 10 LTSB 2016 and not 
pro, but i think i tested it with pro as well (atleast on one or two 
machines) before we got access to the ltsb release.
Only problem i had with windows 10 was when i upgraded from windows 7 to 
windows 10 without a clean install. Then the gpe extension would not 
execute at all and i could not figure out what was causing it, but a 
fresh install fixed it.
And i should add as well that we are using x64 only but this should be 
quite common and fastboot is disabled on all devices.

You can find the latest release of my wpkg-gp mod and official releases 


Since i didn't change anything that should influence boot execution in 
my mod, both should work the same.

I thought this was the official repo https://github.com/cleitet/wpkg-gp 
since the shutdown of google code?

Best Regards,


IT-Support - Fachbereich 09 Kulturgeschichte und Kulturkunde
Universität Hamburg
Flügelbau West, R. 204
Edmund-Siemers-Allee 1
D-20146 Hamburg
Tel.: +49-40-42838-3024
Email: it.service.kultur at uni-hamburg.de

More information about the wpkg-users mailing list