[sheepdog-users] Upgrade from 0.4.0 to 0.5.0?

MORITA Kazutaka morita.kazutaka at lab.ntt.co.jp
Mon Sep 24 19:11:15 CEST 2012

At Sun, 23 Sep 2012 01:44:59 +0700,
icez network wrote:
> Hello,
> I'm currently running sheepdog 0.4.0. As now sheepdog has been released
> version 0.5.0 so I have tried upgrading my cluster.
> My sheepdog cluster consist of 3 servers, each with a gateway (port 7000)
> and a storage node (port 7001) using corosync cluster driver format with 2
> copies. I tried upgrading my test cluster (with same configuration) using
> the following steps:
> 1) stop all running VMs
> 2) execute 'collie cluster shutdown'
> 3) compile sheepdog 0.5.0 using './configure --prefix=/opt/sheep
> --enable-corosync' , make and make install followed
> 4) start the gateway back with command '/opt/sheep/sbin/sheep -g -p 7000
> /var/sheepdog/gw' (use same command with v0.4.0)
> 5) start storage node with command '/opt/sheep/sbin/sheep -p 7001
> /var/sheepdog/disk1' (use same command with v0.4.0)
> At step 4, I found that when I start all gateway, the cluster is in state
> 'Waiting for other nodes to join cluster' which is expected. But when I
> start 2 out of 3 storage nodes in step 5, the cluster state changed to
> 'running' and the recovery process started without waiting for node 3 to
> join the cluster back. This cause my (test) data stored in sheepdog
> currupted and the VM cannot start as some important data is lost.
> I tested the cluster restart process for sheepdog 0.4.0 (step 1,2,4,5
> without changing the sheepdog binary version) and it has no problem. So I
> think it's from the upgrade procedure that 'should have' something more to
> do (like converting something like upgrading from 0.3.0 to 0.4.0?)
> Please tell me if I miss something in the upgrade process.

Sorry for inconvenience.  The sheepdog epoch data layout has changed
from 0.4.0 and you need to upgrade it first.  I'll add a feature to
check and migrate data layout safely ASAP.



More information about the sheepdog-users mailing list