[sheepdog] [PATCH 0/6] introduce sd_getopt to parse command line options

MORITA Kazutaka morita.kazutaka at lab.ntt.co.jp
Tue Nov 6 06:39:15 CET 2012

At Tue, 06 Nov 2012 12:50:55 +0800,
Liu Yuan wrote:
> On 11/06/2012 12:04 PM, MORITA Kazutaka wrote:
> > Well, what I wanted to say is 'prefix' is not an appropriate word for
> > 'zookeeper', 'accord', or 'object', and would like to find out a
> > better name.
> > 
> > Anyway, this is probably a matter of taste and I'm fine with adding a
> > helper named sd_opt_get_prefix.
> Hmm, how about str:substr, substr={key:val,key:val,...}? String is more
> neutral name.

str is not descriptive and it's difficult for developers to imagine
that substr contains key-value pairs.

Anyway, I'll try to create a patch with "<prefix>:<key>=<value>,..."
notation.  Let's see whether it will be better.



More information about the sheepdog mailing list