[Stgt-devel] Errors in fsck with iSER

Robin Humble robin.humble+stgt
Wed Dec 19 10:42:34 CET 2007

On Tue, Dec 18, 2007 at 02:11:24PM +0200, Erez Zilber wrote:
>>>>> We ran some tests on it. Most of them are ok except for fsck. We ran it
>>>>> in the following way:
>>>>> seed5:/tmp/regtest # parted -s /dev/sdb mkpart primary 0 8500
>>>>> seed5:/tmp/regtest # for ((i=1;i<=1000;i++)) do mkfs -t ext2 -q
>>>>> /dev/sdb1; fsck -y -ft ext2 /dev/sdb1; echo iteration $i is done; done
>>>>> fsck is ok most of the time, but once in a while it looks like this
>>>>> (after ~300 iterations):
>Yes, I still see the same bad behavior with iSER. Pete & Robin - can you
>try to run the same test (see above) with iSER and see if you get the
>same behavior?

I ran the script over iSER to backing stores of 8G lustre files and to
a 7G ramdisk and didn't see any problems.

for most of the tests the initiator nodes were run with 8G ram and then
again with 512M ram to try and flush more traffic down the wire.
I tried both osc.edu and mainstream tgtd's. no problems.


More information about the stgt mailing list