[stgt] tgtd locks up

FUJITA Tomonori fujita.tomonori at lab.ntt.co.jp
Sun Aug 14 03:57:50 CEST 2011

On Sun, 31 Jul 2011 17:37:28 -0600
Michael McGlothlin <michaelm at plumbersstock.com> wrote:

> I have a CentOS 5.6 server running scsi-target-utils 1.0.8 and I've
> been running it as an iSCSI server to some ESXi servers for a couple
> weeks. It's worked overall but has a couple issues that seem related
> to it locking up when I try to add it as a target.

You mean that you tried to add a new target?

Or you mean that a new ESXi server tried to connect to the iSCSI

And what locked up? tgt daemon? ESXi? You are sure that it doesn't
crash instead of locking up?

> I've only gotten it
> to work on one of my three (identical) ESXi servers. It stops
> responding when I try to add it or the connection never seems to be
> made even though I see the server and targets show up in ESXi.
> Occasionally it stops responding other times - possibly when under
> higher than average load. One of the CPUs maxes out and never goes
> back down and it just stops responding. When I target it from Windows
> Server it doesn't seem to have a problem (but isn't under nearly the
> same level of usage).
> I'm just teaching myself about iSCSI so I'm not sure if I'm dealing
> with a mistake on my part or a bug. Not finding any obvious answer by
> Googling or experimenting. I divided my disk up into <2GB chunks. My
> current targets.conf looks like this:
> <target iqn.2011-07.dev:storage0>
>  backing-store /dev/disk0
>  backing-store /dev/disk1
>  backing-store /dev/disk2
>  backing-store /dev/disk3
> </target>

To unsubscribe from this list: send the line "unsubscribe stgt" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

More information about the stgt mailing list