[wpkg-users] Server connection failed with RealTek cards

Florian Effenberger floeff at gmail.com
Thu Aug 28 12:50:39 CEST 2008

Hi Tomasz,

thanks for the fast reply!

> Oh, cool. Finally someone has identified a piece of hardware which allows to
> reproduce this problem.


> Could you give me a link where I can buy this card (ebay, or some other
> online shop)? Or a full name, model etc.

It's on two series of Gigabyte mainboards we ordered lately, as
onboard PCI express cards. Don't know the exact board models (they are
on a remote location and not at my home office), but can get them for
your if needed. The card was quite strange right from the beginning.
All drivers available didn't work with RIS. With the help of Gianluigi
Tiesi from http://oss.netfarm.it/guides/pxe.php I was able to find out
why. The driver only were for REV_01, while the card itself identified
to the BINL server without REV_01, where no drivers were available.
After patching the INF file, it worked fine. In Windows, the card is
now known as REV_02 and seem to work even according to the INF file
there is no driver for REV_02...

It has this PCI ID: PCI\VEN_10EC&DEV_8168&SUBSYS_E0001458

> What drivers are you using? Shipped with Windows, or the ones delivered with
> a network card?

Windows has no built-in drivers for it, so I downloaded the latest one
from RealTek.

I think these drivers delay starting one service needed for network
browsing. I normally used cmdlines.txt of Windows setup to install
WPKG from the network, but this didn't work on the new machines, some
service was unable to start (unfortunately I didn't write down which
one). So I moved WPKG installation to the first logon which is done by
autologon directive, and this worked. But now we have the issues with
WPKG not running.

Installing the chipset drivers for the board didn't cure the problem,
by the way.

Any chance to log which error message is shown? I could bet on a
Windows service not ready yet...


More information about the wpkg-users mailing list