[wpkg-users] windows 7 problem with one package

heiko.helmle at horiba.com heiko.helmle at horiba.com
Wed Apr 28 08:40:30 CEST 2010

> > This is a shot in the dark - is "show gui" activated in the wpkg
> > service? I had several packages behave oddly when this was not active
> > (stalling or failing).
> I never thought of that. On your suggestion I tried showing the GUI,
> but the results were the same.  Except that now the Interactive Services 
> does indicate that a process needs some user interaction.  When I try to 
display the 
> window, I see only two black boxes, without any text or buttons.  One of 
the boxes is 
> probably cscript. The other may hold the answer to the problem, but I 
cannot see it.

If there's a command window, you may have run into the WSH stdout-buffer 
bug. Does your installer output something into the command windows? If 
it's too much, you'll need to redirect it to >NUL.

> > Last step would be watching the install with Process Explorer and/pr
> > Process Monitor.
> Good idea.  I started process explorer after the install hung. I 
> tried to bring it to 
> the front, but it said there were no visible windows to display.

Are there any children hanging under the cscript.exe running wpkg? This 
may give you a clue what process is hanging. If it's a cmd.exe directly 
under cscript, it certainly may be the stdout-bug. That points to 
redirecting the output of the script to >NUL

Best Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wpkg.org/pipermail/wpkg-users/attachments/20100428/cb0c1a7e/attachment-0002.html>

More information about the wpkg-users mailing list