[wpkg-users] "new" behaviour since wpkg.js version 1.3.1

Rainer Meier r.meier at wpkg.org
Fri Jun 27 16:18:08 CEST 2014

Hi Holger,

On 27.06.2014 13:35, Holger.Bauer at ricoh.de wrote:
> With wpkg-version 1.3.0 this worked fine, but with version 1.3.1 I receive an
> error message.
> So I tried a few things and found out that I have to put a cmd /c into the
> installation command so that it looks like this:
> <install cmd='cmd /c Netsh advfirewall firewall set rule group="%EnableRDP%" new
> enable=yes' />
> Another information: If I declare the variable in the package itself the cmd /c
> is not necessary and everything works as expected.
> Any ideas???

I think this boils down to some variable substitution change. If you use 'cmd 
/c' then the variable %EnableRDP% is passed to cmd and finally expanded by cmd. 
If you don't use 'cmd /c' prefix variable expansion entirely happens in WPKG only.

I will have to check whether any change in WPKG 1.3.1 lead to issues expanding 
profile or host variables during command execution. But it sounds a little 
strange that the expansion works properly if the variable is specified in the 
package. Perhaps WPKG fails to apply host and profile variables before executing 
the command. Especially strange since during execution of the command the 
variable seems to be defined (else cmd could also not expand it).

I will certainly try to reproduce and report back.


More information about the wpkg-users mailing list