[wpkg-users] WPKG Client 1.2rc6 service doesnt install or start (XP SP2)

Phil Burrow philburrow at blueyonder.co.uk
Fri Jan 11 00:33:29 CET 2008

Tomasz Chmielewski wrote:

> Is it a clean XP SP2 installation? Or it has some "age" now?
> Did you have any earlier versions of WPKG Client installed on that 
> machine? If so, did you install as different users (i.e., Administrator, 

Hi Tomasz,

It's a fairly old machine that was a spare, but I upgraded it to XP SP2 
just a few days ago. But yes the original XP installation is some years 
old. I installed it whilst logged on as a local admin (but not 
specifically the Administrator account), and I told it to run as SYSTEM 
using the GUI.

> You might want to read this:
> http://bugzilla.wpkg.org/show_bug.cgi?id=89
> In particular, try:
> cd %PROGRAMFILES%\wpkg\
> WPKGsrv.exe /install
> WPKGsrv.exe /debug
> And tell what happened (Event Log entries, etc.).

Right. I had already seen that bugzilla thread before posting here but 
it didn't really apply to my scenario.

I executed WPKGSrv.exe /install and it installed the service with no 
problem. WPKG Service now appears in the Services list within the MMC.

When I run WPKGSrv.exe /debug I get the following:

C:\Program Files\wpkg>WPKGSrv.exe /debug
Debugging WPKG Service.
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

At this point it appears to hang and I don't get a cursor. In the Event 
Log I see three entries for WSH reporting that Time Synchronization 
occurred. That's it.

I only have two packages: Acrobat Reader 8.1.1 and time synchronization. 
Acrobat Reader was already installed by WPKG when I ran the script 
manually using \\pdc\wpkg\wpkg-start.bat (modified for my setup of 
course). I don't know if I should have had a message saying WPKG ignored 
Adobe Acrobat Reader, because I didn't get one.

I went into the Services snapin and attempted to start WPKG Service. I 
received the following message as a popup messagebox:

"The WPKG Service service on Local Computer started and then stopped. 
Some services stop automatically when they have no work to do, for 
example the Performance Logs & Alerts service."

In the Event Log I see 6 entries:

Information: WPKG Service trying start...
Information: WPKG Service->RegisterServiceCtrlHandler: successfully done
Information: WPKG Service->SERVICE_START_PENDING: sucessfully done
Information: ServiceStart
Information: Set script security context: successfully done
Error: WNetAddConnection2->A specified logon session does not exist. It 
may already have been terminated.

Any clues from this?


More information about the wpkg-users mailing list