[wpkg-users] Windows 7 Install

Jeff_Applegate at fws.gov Jeff_Applegate at fws.gov
Tue Dec 21 16:02:36 CET 2010

I am getting the error when I am attempting to install the wpkg-client 
software.  I am using the 64bit installer to attempt to install the 
software.  When I right click the file there is no option to run as 
administrator.  My assumption is that the option isn't there due to having 
administrative privileges.  When I attempt to install the software I am 
not getting the log file in %windir%\temp\wpkg-%computername%.log.  My 
best guess on this is that the software is erroring out before it starts 
writing to the temp directory.  I have attempted to adjust the properties 
on the Temp directory to no avail.

Jeff Applegate
ASRC Management Services
Contracted To:
Fort Collins Science Center
2150 Centre Ave., Bldg C
Fort Collins, CO 80526
Phone: 970-226-9178
Fax: 970-226-9230
Email: jeff_applegate at fws.gov

Natxo Asenjo <natxo.asenjo at gmail.com> 
12/21/2010 12:56 AM

Jeff_Applegate at fws.gov
wpkg-users at lists.wpkg.org
Re: [wpkg-users] Windows 7 Install

On Mon, Dec 20, 2010 at 10:12 PM,  <Jeff_Applegate at fws.gov> wrote:
> Has anyone seen the following error:
> First Error Message:
> You must have an administration privilege on this computer.
> Second Error Message:
> There is a problem with this windows installer package. A program run as
> part of this setup did not complete as expected. Contact your support
> personnel or package vendor.
> First I am an administrator on the system as I can install other 
> with no issue.  I have also tried downloading the package from the 
> again.  The package is 1.3.9 and is x64.  I have also attempted to run 
> installer locally.  This is on a clean install of Windows 7 x64.  Any 
> all help is appreciated.

well, it definately looks like a permissions issue :)

Do you get this problem when trying to install the wpkg client software
itself? Or is this a message from a package to be installed by the wpkg
software? I have no x64 windows 7, but I run wpkg x64 with windows
2008r2 without those issues.

If the message is from a wpkg package (wpkg is trying to install another
application, then you need to check some things:

If you run wpkg as a windows service, under what account does it run? I
run the standard package as local system and it just works.

If you run it in a scheduled task, check also the account that is
running this.

As a last (for now) troubleshooting measure, in %windir%\temp there is a
file wpkg-%computername%.log with very detailed info of what wpkg has
done during its last run. Check it out to find errors. you can also run
wpkg from the cli with the /debug flag to see the same info live on a


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.wpkg.org/pipermail/wpkg-users/attachments/20101221/e2b15b0f/attachment-0002.html>

More information about the wpkg-users mailing list